ALLservice Service Forum
support board, PC repair, unlocking solutions
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Restore Lenovo L420 BIOS with CH341a

 
Post new topic   Reply to topic    Service Forum Forum Index -> Hardware, BIOS repairs
View previous topic :: View next topic  
Author Message
WillingMost7
Nou Venit


Joined: 26 Mar 2023
Posts: 1

PostPosted: Sun Mar 26, 2023 2:12 am    Post subject: Restore Lenovo L420 BIOS with CH341a Reply with quote

So my I flashed a bad modded BIOS and I need to reflash using CH341a cause Phoenix BIOS Recovery does not work for some reason.

So far I've learn that my BIOS chip is probably the "25q32bvsig", but I'm unable to read properly and definitely not erase or write to it.

I have both CH341a black verison (which on google it seems I need to do the 3.3 voltage mod for it to work properly) and the green version v1.7 which has voltage controller (so I just set it to 3.3v), I connected the chip with a clip and placed the clip pins correctly (pin number one is facing the opposite side of the USB, accoring to their manual. And it is placed properly on the chip cause if I place it the other way around the light on the CH341a goes darker), but yet it does not recognize the chip at all.

If I play a bit with connecting the battery to the laptop and disconnecting it, CH341a recognizes the BIOS chip and sometimes even reads from it but cannot erase or write (and even then if I am able to read for a second time it shown a completely different read/characters). I am able to turn off protection, but it seems to me like it just does not work (sometimes when I try to turn off protection it processes forever and does not let make other operations cause it is not able to finish this one).

I am working with NeoProgrammer v2.2.0.10, also tried AsProgrammer v1.4. Installed CH341a drivers. Got the FL1 BIOS file truncated and it is not pre compressed.

Also an error I got sometimes after keep spamming and disconnecting and reconnecting everything possible is: "WARNING, probable erasure failure".


Hope I got it all covered. I am really lost and would be grateful to get some help please. Thanks in advance!
Back to top
View user's profile Send private message
victor
S.F. Boss


Joined: 07 Mar 2004
Posts: 2562
Location: Staff

PostPosted: Tue Mar 28, 2023 12:47 pm    Post subject: Reply with quote

Hi there,

Well, I can only help you if you use my SPEG programmer that I specially made it for in-system programming. CH341 is a cheap device that may work or may not. Anyway, I can't provide assistance for other programmers, you should ask their manufacturers.

Our SEPG is available here. www.allservice.ro/store/utils/

Anyway, regarding nhe BIOS in L420, indeed it's a 32Mbit (4Mbyte) SPI flash. And we can repair the original BIOS if you saved a copy, of it or we can build a new one from scratch, fix the MERegion with correct CPU tables and inject a TCPA certificate fix and a DASH table with checksums and all.
_________________
Victor Voinea
ALLservice HQ, Romania.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    Service Forum Forum Index -> Hardware, BIOS repairs All times are GMT + 2 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum



Powered by phpBB © 2001, 2005 phpBB Group